summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxwell Pray2022-08-15 12:35:38 -0700
committerMaxwell Pray2022-08-15 12:35:38 -0700
commitcd464f8c887a821963523c94222aac1b94187069 (patch)
tree859e7fd38ea77028439c08ab6e0431a647024431 /PKGBUILD
downloadaur-vim-local-history-git.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5944eb9657c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Maxwell Pray <synthead@gmail.com>
+
+_pkgname=vim-local-history
+pkgname=$_pkgname-git
+pkgver=r4.db671dc
+pkgrel=1
+pkgdesc="Use viminfo file relative to current working directory."
+arch=("any")
+url="https://github.com/maxboisvert/vim-local-history"
+license=("GPL3")
+source=("git+https://github.com/maxboisvert/vim-local-history.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm 644 "$srcdir/$_pkgname/plugin/vim-local-history.vim" "$pkgdir/usr/share/vim/vimfiles/plugin/vim-local-history.vim"
+}