summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLiao Junxuan2023-11-14 16:09:52 +0800
committerLiao Junxuan2023-11-14 16:09:52 +0800
commit19782c46124e1953b5454ddc6a8ed696bdad44fb (patch)
treeb90ca04cd365d504fb27b7b8837732858ddba9e0 /PKGBUILD
downloadaur-vim-lumen.tar.gz
add vim-lumen
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1971f50b45f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Junxuan Liao <mikeljx at 126 dot com>
+# Contributor: Adam Schadler <ajschadler@gmail.com>
+pkgname=vim-lumen
+pkgver=1.0
+pkgrel=1
+pkgdesc="Vim plugin that makes vim follow your system-wide dark mode preference"
+arch=('any')
+url="https://github.com/vimpostor/vim-lumen"
+license=('GPL-3.0-only')
+groups=('vim-plugins')
+depends=('vim-runtime' 'glib2')
+optdepends=(
+ "plasma-desktop: supported color switcher"
+ "gnome-desktop: supported color switcher"
+ "darkman: supported color switcher"
+ "color-scheme-simulator: supported color switcher"
+)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('44593b97d0815695f9750211d00d41776ba11bcdc2a04b9db69ab9488bb235c1')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ local _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -d "${_installpath}"
+ find autoload doc plugin -type f -exec \
+ install -Dm 644 '{}' "${_installpath}/{}" \;
+}
+