summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-04-27 15:10:36 -0500
committerLuis Martinez2021-04-27 15:10:36 -0500
commit64f1fc3d2c219c741c360c4b34c605b1691a3e39 (patch)
tree036dc52f4207747336d1928fc08c83461e41a47f /PKGBUILD
downloadaur-vim-mkdx.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67a598b19eec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-mkdx
+pkgver=1.10.0
+pkgrel=1
+pkgdesc="Vim plugin that adds Markdown-related features"
+arch=('any')
+url="https://github.com/sidofc/mkdx"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+optdepends=('vim-repeat: Compatible plugin')
+changelog=CHANGELOG.md
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/sidofc/mkdx/v$pkgver/CHANGELOG.md")
+sha256sums=('acc09a8367aab71baa292f5cf0a81e587ee01a150e7c027eb99d9079ec1e0977'
+ 'ec5c9cbb3b71abb57738b4db098143e497ac0ea16b96275e6cc3daca07916d5f')
+
+package() {
+ cd "mkdx-$pkgver"
+ find after autoload doc ftplugin plugin ! -name '*.gif' \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}