summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorml2020-07-22 02:01:06 +0200
committerml2020-07-22 02:01:06 +0200
commit0f5d92e74388c135e3664e09fc3a598cc7f6c946 (patch)
treefa11b376893855f684b95895bf3ac34fc33acf40 /PKGBUILD
downloadaur-vim-mustache-handlebars-git.tar.gz
newpkg: vim-mustache-handlebars-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b15f17ef26f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: ml <ml@visu.li>
+pkgname=vim-mustache-handlebars-git
+pkgver=r145.697fa02
+pkgrel=1
+pkgdesc="Vim plugin for mustache and handlebars"
+arch=('any')
+url='https://github.com/mustache/vim-mustache-handlebars'
+license=('unknown')
+groups=('vim-plugins')
+depends=('vim')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm644 example.mustache README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -dm755 "$pkgdir/usr/share/vim/vimfiles"
+ cp -rt "$pkgdir/usr/share/vim/vimfiles" indent ftdetect ftplugin syntax
+}