summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeo2022-02-08 13:42:11 +0800
committerLeo2022-02-08 13:42:53 +0800
commitc699dddd005de574458b0564cc82ea7eb1a35421 (patch)
treef1b8756798d873a24e00470e00034a0178fa633f /PKGBUILD
parent277ee292b0d20c5bed8498ff2945b25e4e960409 (diff)
downloadaur-vim-pgsql.tar.gz
Port untagged upstream updates.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c669f21cfec..aa7bac36faf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_reponame=pgsql.vim
pkgname=vim-pgsql
pkgver=2.3.1
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="Vim syntax highlighting and auto-completion support for PostgreSQL"
arch=('any')
@@ -20,11 +20,19 @@ backup=()
options=()
install=
changelog=
-source=("$pkgname-$pkgver.tar.gz::https://github.com/lifepillar/pgsql.vim/archive/refs/tags/v$pkgver.tar.gz")
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/lifepillar/pgsql.vim/archive/refs/tags/v$pkgver.tar.gz"
+ "20220208-upstream.patch"
+)
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP' 'SKIP')
validpgpkeys=()
+prepare() {
+ cd $srcdir/$_reponame-$pkgver
+ patch -p1 -i "$srcdir/20220208-upstream.patch"
+}
+
package() {
install -D -m 644 \
$srcdir/$_reponame-$pkgver/syntax/pgsql.vim \