summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChandler Klüser2023-12-19 19:40:41 -0300
committerChandler Klüser2023-12-19 19:40:41 -0300
commit3b885c38297fcd398d1f586999f71f76e8f8a8be (patch)
tree0898dc9a2191c5481d1603960737098927d2e711 /PKGBUILD
parent48eadd6f1d79b801bf643616db44bd908cdddbbc (diff)
downloadaur-vircon32-desktop-emulator-git.tar.gz
Upgrade to 2f5b85bbead2ecafed9394cabe7e0a6e26676148
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 22 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aba30b828fd9..13fb1a297fd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Chandler Klüser <chandler.kluser@gmail.com>
pkgname=vircon32-desktop-emulator-git
-pkgver=24770a4337f52553a792bbe618377297794149ae
+pkgver=2f5b85bbead2ecafed9394cabe7e0a6e26676148
pkgrel=1
-epoch=20230909
+epoch=20231219
pkgdesc="Vircon32 Desktop Emulator"
arch=('x86_64')
url="https://github.com/vircon32/ComputerSoftware"
@@ -14,13 +14,29 @@ depends=('mesa' 'sdl2' 'sdl2_image' 'openal' 'freealut' 'tinyxml2' 'gtk2')
makedepends=('glibc' 'git' 'cmake')
provides=('vircon32-desktop-emulator')
source=("ComputerSoftware::git+$url.git")
-md5sums=('SKIP')
+sha256sums=('SKIP')
-package() {
+build() {
cd ComputerSoftware/DesktopEmulator
mkdir build && cd build
-
cmake ..
cmake --build .
- make DESTDIR="$pkgdir" install
+}
+
+package() {
+ install -d "${pkgdir}/opt/Vircon32/Emulator"
+ install -d "${pkgdir}/opt/Vircon32/Emulator/Bios"
+ install -d "${pkgdir}/opt/Vircon32/Emulator/Images"
+ install -d "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/share/pixmaps"
+ install -d "${pkgdir}/usr/share/icons/hicolor/scalable/apps/"
+ cp -r ComputerSoftware/DesktopEmulator/build/* "${pkgdir}/opt/Vircon32/Emulator"
+ cp ComputerSoftware/DesktopEmulator/Data/Config-Controls.xml "${pkgdir}/opt/Vircon32/Emulator"
+ cp ComputerSoftware/DesktopEmulator/Data/Config-Settings.xml "${pkgdir}/opt/Vircon32/Emulator"
+ cp ComputerSoftware/DesktopEmulator/Data/Bios/StandardBios.v32 "${pkgdir}/opt/Vircon32/Emulator/Bios/StandardBios.v32"
+ cp ComputerSoftware/DesktopEmulator/Data/GuiFont.ttf "${pkgdir}/opt/Vircon32/Emulator"
+ cp -r ComputerSoftware/DesktopEmulator/Data/Images/* "${pkgdir}/opt/Vircon32/Emulator/Images"
+ cp ComputerSoftware/DesktopEmulator/Resources/Linux/Vircon32.desktop "${pkgdir}/usr/share/applications"
+ cp ComputerSoftware/DesktopEmulator/Resources/Linux/Vircon32.svg "${pkgdir}/usr/share/pixmaps"
+ cp ComputerSoftware/DesktopEmulator/Resources/Linux/Vircon32.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/"
}