summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Bouvier2024-04-30 21:46:14 +0200
committerAlexandre Bouvier2024-04-30 21:46:14 +0200
commit795b77445ac23837fd2df27d67b0067c3e76c8ae (patch)
tree00c313dfbb19f2f695a93fdbe34d83bfcded44b2 /PKGBUILD
parentd588f0fca39016c07293a21c8359390fd09d4504 (diff)
downloadaur-virtualsmartcard-git.tar.gz
update to 0.9.r9.gd2e607f
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df77ef298bc8..d95770234eb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=virtualsmartcard
pkgname=$_pkgname-git
-pkgver=0.8.r65.g38709f3
+pkgver=0.9.r9.gd2e607f
pkgrel=1
pkgdesc="Smart card emulator written in Python"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://frankmorgner.github.io/vsmartcard/virtualsmartcard/README.html"
-license=('GPL3')
-depends=(
- 'pcsclite'
- 'python-pillow'
- 'python-pycryptodomex'
- 'python-pyscard'
- 'python-qrcode'
- 'qrencode'
-)
+license=('GPL-3.0-only')
+depends=('glibc' 'pcsclite' 'python' 'python-qrcode' 'qrencode')
makedepends=('git' 'help2man')
+optdepends=(
+ 'openpace: emulation of German identity card with –type=nPA'
+ 'python-pillow: emulation of electronic passport with –type=ePass'
+ 'python-pycryptodomex: emulation of electronic passport with –type=ePass'
+ 'python-pyscard: relaying a local smart card with –type=relay'
+)
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=('vsmartcard::git+https://github.com/frankmorgner/vsmartcard.git')