summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjose17112017-08-20 00:30:00 +0200
committerjose17112017-08-20 00:30:00 +0200
commit88a1e791a269eecf211aa891313c557aa97b1d76 (patch)
treeb6d013200f67c2664b7804a00e8250b373761221 /PKGBUILD
parent915a47f1dfdd02d47e0edd290836ced79a4450e5 (diff)
downloadaur-virtuoso6.tar.gz
Fix building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 049a7e1adad1..04ae24173f9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@
pkgname=virtuoso6
pkgver=6.1.8
_pkgname=virtuoso
-pkgrel=1
-arch=('i686')
+pkgrel=2
+arch=('i686' 'x86_64')
url='http://virtuoso.openlinksw.com/wiki/main/Main/'
license=('GPL')
pkgdesc='Virtuoso is a scalable cross-platform server that combines Relational,\
Graph, and Document Data Management with Web Application Server and Web \
Services Platform functionality. This is currently the latest version available for i686 architecture.'
-depends=('libldap' 'imagemagick' 'java-environment')
+depends=('libldap' 'imagemagick' 'java-environment' 'openssl-1.0')
makedepends=('bison' 'flex' 'gperf' 'net-tools' 'optipng')
replaces=('virtuoso-base')
provides=('virtuoso-base')
@@ -31,10 +31,10 @@ prepare() {
build() {
cd ${_pkgname}-opensource-${pkgver}
-
- ./configure --with-layout=debian \
- --program-transform-name='s/isql$$/isql-vt/;s/isqlw/isqlw-vt/' \
- --with-readline
+ CFLAGS="-I/usr/include/openssl-1.0" LDFLAGS="-L/usr/lib/openssl-1.0" \
+ ./configure --with-layout=debian \
+ --program-transform-name='s/isql$$/isql-vt/;s/isqlw/isqlw-vt/' \
+ --with-readline
make
}