summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Feletto2021-01-16 13:57:50 +0100
committerAndrea Feletto2021-01-16 13:57:50 +0100
commita526ff75b2968ed4b29eaba9b6057036b93a27c1 (patch)
treec76aac42cc5fb38fff596eade1bfdaf4254c5bac /PKGBUILD
parentd50af90869b79d4df30e98f855e2ec4d598e24e3 (diff)
downloadaur-vis-base16-git.tar.gz
fixed description and added docs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 247a3d8c9156..9e762fafa5d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,28 @@
# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
pkgname=vis-base16-git
-_pkgname=base16-vis
+_pkgname=${pkgname%-*}
pkgver=r6.05dae61
-pkgrel=1
-pkgdesc='cscope interface for the vis editor.'
+pkgrel=2
+pkgdesc='Themes for the vis editor.'
arch=('any')
url='https://github.com/pshevtsov/base16-vis'
license=('MIT')
depends=('vis')
provides=('vis-base16')
-conflicts=('vis-base16')
-source=("git+https://github.com/pshevtsov/$_pkgname.git")
+source=("$_pkgname::git+https://github.com/pshevtsov/base16-vis.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- vispath="$pkgdir/usr/share/vis/themes"
- licenses="$pkgdir/usr/share/licenses/${pkgname%-git}"
+ cd "$srcdir/$_pkgname"
- cd "$srcdir/$_pkgname"
- install -dv "$vispath"
- cp themes/* "$vispath"
- install -Dm644 LICENSE "$licenses/LICENSE"
+ install -Dm644 themes/* -t "$pkgdir/usr/share/vis/themes"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
}