summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-08-15 12:51:58 +0200
committerFabioLolix2023-08-15 12:51:58 +0200
commit205972bfce1d4f499a71f288b2e330275606e29e (patch)
treeda6d3ee06b28813d4c2b01fc4f9dfcf7861abbca /PKGBUILD
parent9fba5c7b07d4bccc21cdc6bc8cf94ee9c6085dda (diff)
downloadaur-vkbasalt-cli.tar.gz
new python packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2eeb3a07fc64..8ec6ef512351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
pkgname=vkbasalt-cli
pkgver=3.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Command-line utility for vkBasalt"
arch=(any)
url="https://gitlab.com/TheEvilSkeleton/vkbasalt-cli"
license=(LGPL3)
depends=(python)
-makedepends=(git python-setuptools)
+makedepends=(git python-build python-wheel python-installer python-setuptools)
source=("git+https://gitlab.com/TheEvilSkeleton/vkbasalt-cli.git#tag=v${pkgver}")
sha256sums=('SKIP')
build() {
cd vkbasalt-cli
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd vkbasalt-cli
- python setup.py install --skip-build --optimize=1 --prefix=/usr --root="${pkgdir}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
} \ No newline at end of file