summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorheavysink2021-01-30 02:56:38 -0500
committerheavysink2021-01-30 02:56:38 -0500
commit29c5bfc3e01a64f9a3ea4220926902a5a0cd8e0b (patch)
tree8c073d565c7f0939a5e2b787fe6ab7ebf47b956e /PKGBUILD
downloadaur-vkd3d-proton-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..125904d6f178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Bruce Zhang
+
+pkgname=vkd3d-proton-git
+pkgver=v2.1.r38.g2560c768
+pkgrel=1
+pkgdesc='Direct3D 12 to Vulkan translation library By WineHQ'
+arch=('x86_64')
+url='https://wiki.winehq.org/Vkd3d'
+license=('LGPL')
+depends=('spirv-tools' 'vulkan-icd-loader')
+makedepends=('git' 'meson' 'glslang' 'wine' 'xcb-util-keysyms' 'xorgproto')
+source=("git+https://github.com/HansKristian-Work/vkd3d-proton.git")
+provides=('vkd3d-proton')
+conflicts=('vkd3d-proton')
+md5sums=('SKIP')
+
+pkgver() {
+ cd vkd3d-proton
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+prepare() {
+ cd vkd3d-proton
+ git submodule update --init --recursive
+}
+
+package() {
+ cd vkd3d-proton
+ meson --buildtype release --prefix /usr build.64
+ DESTDIR=$pkgdir ninja -C build.64 install
+}