summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2023-11-28 17:14:19 -0300
committerDaniel Bermond2023-11-28 17:14:19 -0300
commit28848f67c51ba5089d76208c69ab48f9d68a86f1 (patch)
tree4d6e0138f42d41e8fdab8137f682235cf35d7b17 /PKGBUILD
parent86d9159eb086a89aaf07e17d697d5a6344d94321 (diff)
downloadaur-vmaf-git.tar.gz
Match latest upstream changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68d67a60231e..b8515986d37a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,36 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=vmaf-git
-pkgver=2.3.0.r89.g278f6aba
+pkgver=3.0.0rc.r1.g97e50eae
pkgrel=1
pkgdesc='Perceptual video quality assessment algorithm based on multi-method fusion (git version)'
arch=('x86_64')
url='https://github.com/Netflix/vmaf/'
license=('BSD')
depends=('gcc-libs')
-makedepends=('git' 'meson' 'nasm' 'vim' 'doxygen')
+makedepends=('git' 'meson' 'nasm')
+checkdepends=('vim')
provides=('vmaf' 'libvmaf-git')
conflicts=('vmaf' 'libvmaf-git')
replaces=('libvmaf-git')
-options=('!lto')
source=('git+https://github.com/Netflix/vmaf.git')
sha256sums=('SKIP')
pkgver() {
- git -C vmaf describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C vmaf describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;s/\.rc/rc/'
}
build() {
- arch-meson vmaf/libvmaf/build vmaf/libvmaf
- ninja -v -C vmaf/libvmaf/build
+ arch-meson -Denable_avx512='false' vmaf/libvmaf build
+ meson compile -C build
}
check() {
- ninja -v -C vmaf/libvmaf/build test
+ meson test -C build
}
package() {
- DESTDIR="$pkgdir" ninja -v -C vmaf/libvmaf/build install
- install -D -m755 vmaf/libvmaf/build/tools/vmafossexec -t "${pkgdir}/usr/bin"
+ meson install -C build --destdir "$pkgdir"
install -D -m644 vmaf/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
cp -dr --no-preserve='ownership' vmaf/model "${pkgdir}/usr/share"
}