summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2018-08-01 09:17:04 +0200
committerAlexander F. Rødseth2018-08-01 09:17:04 +0200
commitb22ad829e7c50c8e4c51cae43dff48d01b3bb4c9 (patch)
tree5a7e4270d32a2b82199ce2be4925504c669815e8 /PKGBUILD
parentdcf314b165217967826a9aee5aa14fbedeb50f42 (diff)
downloadaur-vmir.tar.gz
Update the binfmt_misc configuration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dff394a0737..7783c7bdf646 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vmir
pkgver=0.1
-pkgrel=1
+pkgrel=2
pkgdesc='Execute .wasm files directly'
arch=('x86_64')
url='https://github.com/andoma/vmir'
@@ -11,18 +11,16 @@ makedepends=('clang' 'git')
source=("git+https://github.com/andoma/vmir.git#commit=b8aebf545cbf570c9e4367cf8f162db457c06bc0"
'wasm.conf')
sha256sums=('SKIP'
- 'f2f9a8401e8ab2ded3b655477e8eecc8cb4798178512bf8a15cf2263a572cd16')
+ 'b10ca7ae90b202b0e1ffb72cfcdd06a5ab9e304b60ee9831854879c0950bf90c')
prepare() {
sed -i \
- 's,Need .bc file to parse/run,Please pass a .wasm file as the first argument.,g' \
+ 's,Need .bc file to parse/run,Please provide a .wasm file as the first argument.,g' \
"$pkgname/src/main.c"
}
build() {
- cd "$pkgname"
-
- CC=clang make
+ CC=clang make -C "$pkgname"
}
package() {
@@ -30,7 +28,6 @@ package() {
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- # TODO: Make sure the magic header for WASM is correct
install -Dm644 "$srcdir/wasm.conf" "$pkgdir/etc/binfmt.d/wasm.conf"
}