summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel LeWarne2016-07-28 20:35:44 -0400
committerDaniel LeWarne2016-07-28 20:35:44 -0400
commit1b1cdaaa3d533b54cc282b34276cec563d9defe6 (patch)
tree3664337d81f9abd73ee405f7fba9ec2c056bc11a /PKGBUILD
downloadaur-vndc-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e640c252a0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: yubimusubi
+
+_pkgbase=vndc
+pkgname=${_pkgbase}-git
+pkgver=2
+pkgrel=1
+pkgdesc="vndc - VNDC is Not a Direct Clone (of VNDS ;P)"
+arch=('i686' 'x86_64')
+url='https://github.com/chaoskagami/vndc'
+license=('GPL')
+depends=('sdl2_mixer' 'sdl2_image' 'sdl2_ttf')
+provides=('vndc')
+conflicts=('vndc')
+# Dependency 'smpeg' 'bzip2' already satisfied
+source=(git+https://github.com/chaoskagami/vndc.git)
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${_pkgbase}"
+ ./autogen.sh
+ ./configure --prefix=${pkgdir}/usr
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+ make install
+
+ install -dm755 "${pkgdir}/usr/share/doc/${_pkgbase}"
+ install -m644 README.md LICENSE SCRIPTINGDOC.md "${pkgdir}/usr/share/doc/${_pkgbase}"
+}
+
+# vim:set ts=2 sw=2 et: