summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDamien Flament2017-03-06 21:53:32 +0100
committerDamien Flament2017-03-06 21:53:32 +0100
commit5ebfb63ab06259038700c3df5027904c231a4305 (patch)
tree710b47cf3684b1b79c121305c0314f62d800c0db /PKGBUILD
parent97975af5a04ad790d0875cb9a9f4bab9c9c1c53e (diff)
downloadaur-5ebfb63ab06259038700c3df5027904c231a4305.tar.gz
The redistribuable seems to be "custom licensed".
As the redistribuable contains a custom license witch states that VoxelShop is a Freeware, it should be mark as custom licensed. Even if the GitHub repository constains an Apache license file. It is certainly due to the tools used to make the redistribuable. Confirmation was asked by e-mail to the software owner.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8990f2a76f21..55484006b902 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver=1.8.02
pkgrel=1
pkgdesc='VoxelShop is an extremely intuitive and powerful cross-platform software to modify and create voxel objects was designed from the ground up in close collaboration with artists.'
url=http://blackflux.com/node/11
-license=('Apache')
+license=('custom')
groups=()
depends=('java-runtime-common')
makedepends=()
@@ -33,4 +33,7 @@ package() {
chown -R $USER:users ${pkgdir}/opt/${pkgname}
install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
ln -s ${pkgname} ${pkgdir}/usr/bin/${_pkgname_upper}
+
+ cd ${srcdir}/${_pkgname_upper}
+ install -D License.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}