diff options
author | mydongistiny | 2019-09-29 14:06:12 -0700 |
---|---|---|
committer | mydongistiny | 2019-09-29 14:06:17 -0700 |
commit | 7b956e6fe4f1adc2a9ef55c0aaca2457c38f0bb4 (patch) | |
tree | bfcfe8628ac0a9da41e4def4266fa7e6a5f1b018 /PKGBUILD | |
parent | 5c416a75314bdcdb9b3ffd2fa874af2a69a15472 (diff) | |
download | aur-7b956e6fe4f1adc2a9ef55c0aaca2457c38f0bb4.tar.gz |
Update PKGBUILD for meson and 0.58.0
Signed-off-by: mydongistiny <jaysonedson@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 42 |
1 files changed, 12 insertions, 30 deletions
@@ -2,61 +2,45 @@ # Contributor: Manuel Hüsers <manuel.huesers@uni-ol.de> # Contributor: Fernando Fernandez <fernando@softwareperonista.com.ar> # Contributor: Ionut Biru <ibiru@archlinux.org> +# Contributor: Jason Edson <jaysonedson@gmail.com> pkgbase='vte3-notification' pkgname=("${pkgbase}" 'vte-notification-common') -pkgver=0.56.3 -pkgrel=2 +pkgver=0.58.0 +pkgrel=1 pkgdesc='Virtual Terminal Emulator widget for use with GTK3 with Fedora patches' arch=('i686' 'x86_64') url='https://wiki.gnome.org/Apps/Terminal/VTE' license=('LGPL') depends=('gtk3' 'pcre2' 'gnutls') -makedepends=('git' 'intltool' 'gobject-introspection' 'gtk-doc' 'vala' 'gperf' 'glade') +makedepends=('git' 'intltool' 'gobject-introspection' 'gtk-doc' 'meson' 'pango' 'vala' 'gperf' 'glade') options=('!emptydirs') # Fedora patches: https://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/ _frepourl='https://src.fedoraproject.org/rpms/vte291' _frepobranch='f30' -_fpatchfile='vte291-command-notify-scroll-speed.patch' -_fcommit='94ec580d203552c728f6d46ce539fd321d991500' +_fpatchfile='vte291-cntnr-precmd-preexec-scroll.patch' +_fcommit='b067afd77f6dbc789b9844dbe4b455ed77540464' # VTE source ref -#_vtecommit='837cce9ced6bfe317cb97aeca171001da92cb3a1' _vtetag=${pkgver} source=( - #"git+https://git.gnome.org/browse/vte#commit=$_vtecommit" "git+https://git.gnome.org/browse/vte#tag=$_vtetag" "${_fpatchfile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile}" - 'add-zsh-notfication-support.patch' ) sha256sums=('SKIP' - '5de49179d88acba730e7446913724ca012b4b5aedb6392b2547a11725829180b' - '150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a') - -#pkgver() { -# cd vte -# git describe --tags | sed 's/-/+/g' -#} + '9e2f27aad738d11226161f066c0eefc831a3aa1ec6f043d53104382a8e752d2d') prepare () { cd "vte" patch -p1 -i "../${_fpatchfile}-${_fcommit}" - #patch -p1 -i '../add-zsh-notfication-support.patch' - - NOCONFIGURE=1 ./autogen.sh } build() { - cd "vte" - ./configure --prefix='/usr' --sysconfdir='/etc' \ - --libexecdir='/usr/lib/vte' \ - --localstatedir='/var' --disable-static \ - --enable-introspection --enable-glade-catalogue --enable-gtk-doc - sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool - make + arch-meson vte build -D docs=true + ninja -C build } package_vte3-notification(){ @@ -64,10 +48,9 @@ package_vte3-notification(){ provides=("vte3=${pkgver}") conflicts=('vte3') - cd "vte" - make DESTDIR="${pkgdir}" install + DESTDIR="${pkgdir}" meson install -C build - rm "${pkgdir}/etc/profile.d/vte.sh" + mv "$pkgdir/etc/profile.d/vte.sh" "$srcdir" } package_vte-notification-common() { @@ -76,7 +59,6 @@ package_vte-notification-common() { arch=('any') provides=("vte-common=${pkgver}") conflicts=('vte-common') - cd "vte" - install -Dm644 'src/vte.sh' "${pkgdir}/etc/profile.d/vte.sh" + install -Dt "$pkgdir/etc/profile.d" -m644 vte.sh } |