summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraksr2015-06-28 07:40:32 +0200
committeraksr2015-06-28 07:40:32 +0200
commit45889f768466c9b3a8a8e824be3c8f9c642cf518 (patch)
treeb0654b743cca37964fd31d90a476d1090f6b1165 /PKGBUILD
downloadaur-wakeup-git.tar.gz
Start.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68dcd98ba30b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Sara <sara at archlinux dot us>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=wakeup-git
+pkgver=49db7f6
+pkgrel=1
+pkgdesc="A timer that will wake your system from suspend to RAM."
+arch=('i686' 'x86_64')
+url="https://github.com/fogobogo/wakeup"
+license=('GPL')
+depends=('linux-api-headers' 'pm-utils')
+makedepends=('git')
+provides=('wakeup')
+conflicts=('wakeup')
+source=("$pkgname::git+https://github.com/fogobogo/wakeup.git")
+md5sums=('SKIP')
+
+pkgver(){
+ cd "${srcdir}/$pkgname"
+ git describe --always | sed 's|-|.|g'
+}
+
+build(){
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package(){
+ cd "${srcdir}/${pkgname}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}
+