summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScott W. Dunlop2015-12-27 18:39:53 -0800
committerScott W. Dunlop2015-12-27 18:41:19 -0800
commite819377de7f341fe6b415194fb749105b2303a40 (patch)
treeb19c07ed87296b4c1497b7956391563c5161d39a /PKGBUILD
downloadaur-walter-git.tar.gz
introduction of walter-git pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d6dc63ed6c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Scott Dunlop <swdunlop@gmail.com>
+pkgname=walter-git
+pkgver=1.3.0.r10.g393c3b7
+pkgrel=1
+pkgdesc='a tiny deployment pipeline'
+arch=("x86_64" "i686") # probably arm; verification welcome
+url="http://walter-cd.net/"
+license=('Apache')
+groups=()
+depends=('glibc')
+makedepends=('git' 'go') # godep may use git when it fetches dependencies
+provides=("walter")
+conflicts=("walter")
+replaces=()
+backup=()
+options=()
+install='walter.install'
+noextract=()
+source=(
+ 'walter::git+https://github.com/swdunlop/walter'
+ 'walter@.service'
+)
+md5sums=('SKIP'
+ 'a8fbee5cdd303bcab7df3c22fadcbc51')
+
+# This version will not build, due to some missing dependencies -- swdunlop@gmail.com
+# pkgname=walter
+# pkgver=1.3.0
+# source=("https://github.com/walter-cd/walter/archive/v${pkgver}.zip")
+# md5sums=('844826f168778711aa7b5a98d5043045')
+
+# uses the last tag as a base, along with revision count and last commit hash (and trims off that v)
+pkgver() {
+ cd "$srcdir/walter"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/walter"
+ ./build
+}
+
+check() {
+ cd "$srcdir/walter"
+ ./test.sh
+}
+
+package() {
+ cd "$srcdir/walter"
+ install -Dm0755 -o root -g root bin/walter "$pkgdir/usr/bin/walter"
+ install -Dm0644 -o root -g root "$srcdir/walter@.service" "$pkgdir/usr/lib/systemd/system/walter@.service"
+}