summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-03-15 14:27:25 -0500
committerLuis Martinez2022-03-15 14:27:25 -0500
commit16b5c31e4211b51dce2b1b6b33e1be73381edefd (patch)
tree1dc1c3169a8dce78bbc36a676be434428a7a9bf1 /PKGBUILD
parentbbfe62946301395a22adcc7e8c41d1f2976b562e (diff)
downloadaur-wapanel.tar.gz
package cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a01bf12c7c7..36f3da63347b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: kiasoc5 <kiasoc5 at tutanota dot com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: kiasoc5 <kiasoc5 at tutanota dot com>
pkgname=wapanel
pkgver=1.1.0
-pkgrel=1
-pkgdesc="Simple panel/status bar/task bar for your custom stacking Wayland-based desktop."
+pkgrel=2
+pkgdesc="Wayland panel and taskbar"
arch=('x86_64')
url="https://github.com/Firstbober/wapanel"
license=('MIT')
-depends=('gtk-layer-shell' 'gtk3' 'wayland' 'wayland-protocols' 'libpulse' 'xdg-utils' 'wlroots')
-makedepends=('meson' 'toml11' 'pkgconf')
-source=(https://github.com/Firstbober/${pkgname}/archive/refs/tags/${pkgver}.tar.gz)
+depends=('gtk-layer-shell' 'gtk3' 'wayland-protocols' 'libpulse' 'xdg-utils')
+makedepends=('meson' 'toml11')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('4f2f11f0d001b4507b5b1dc6622df68a9e786f590cabf603bc5a3b296039f0a5')
build() {
- arch-meson "$pkgname-$pkgver" build
- meson compile -C build
+ arch-meson "$pkgname-$pkgver" build
+ meson compile -C build
}
package() {
- meson install -C build --destdir "$pkgdir"
- install -Dm644 "$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ meson install -C build --destdir "$pkgdir"
+ install -Dm644 "$pkgname-$pkgver/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}