summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2018-08-21 23:29:46 -0400
committerJean Lucas2018-08-21 23:29:46 -0400
commitdcdf3bcb7790e1719b7727d4dcfe19b847bb6c4f (patch)
treed2b35bae0265bd3c1559b5d908be6564faa5e8fd /PKGBUILD
parent7167df0b7112c2f9dc98360ce73af6eeb477fb93 (diff)
downloadaur-way-cooler-bg-git.tar.gz
Rework
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ff264ca8867..a34db73525b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
pkgname=way-cooler-bg-git
-pkgver=0.3.0.75.g9dde66b
+pkgver=0.3.0+75+g9dde66b
pkgrel=1
-pkgdesc="The program that draws a background for Way Cooler"
-arch=('i686' 'x86_64')
-url="https://github.com/way-cooler/way-cooler-bg"
-license=('MIT')
-depends=('way-cooler')
-makedepends=('cargo' 'rust')
-source=("${pkgname}::git+https://github.com/way-cooler/way-cooler-bg.git")
-sha256sums=('SKIP')
+pkgdesc='The program that draws a background for Way Cooler (git)'
+arch=(i686 x86_64)
+url=https://github.com/way-cooler/way-cooler-bg
+license=(MIT)
+depends=(way-cooler)
+makedepends=(rust)
+provides=(way-cooler-bg)
+conflicts=(way-cooler-bg)
+source=(git+$url)
+sha512sums=(SKIP)
pkgver() {
- cd $pkgname
- echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git describe --always)"
+ cd ${pkgname/-git//}
+ echo "$(grep '^version =' Cargo.toml | head -n1 | cut -d\" -f2)+$(git rev-list --count HEAD)+g$(git describe --always)"
}
build() {
- cd "$srcdir/$pkgname"
+ cd ${pkgname/-git//}
cargo build --release
}
package() {
- install -D -m755 "$srcdir/$pkgname/target/release/wc-bg" "$pkgdir/usr/bin/wc-bg"
+ cd ${pkgname/-git//}
+ install -D target/release/wc-bg "$pkgdir"/usr/bin/way-cooler-bg
+ install -Dm 644 -t "$pkgdir"/usr/share/licenses/way-cooler-bg LICENSE
}