summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Johansen2024-03-16 20:13:06 +0100
committerDan Johansen2024-03-16 20:13:06 +0100
commitcf3bbb57ec003b3716909eea3f02cc9f047de269 (patch)
treeae6071bd1f90f13b44f9e276db93afb4d413f1b6 /PKGBUILD
parent6795e80ed04cade0386004dfe3a223df4e932c61 (diff)
downloadaur-wayfire-plugins-toplevel-manager.tar.gz
fix compilation against wlroots 0.17
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a6dc892d0ec..d878c842ed65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,26 @@
_pkgname=windowmanager
pkgname=wayfire-plugins-toplevel-manager
pkgver=0.8.0
-pkgrel=2
+pkgrel=3
pkgdesc="A general window management protocol, and its implementation for Wayfire in the form of wayfire plugin"
arch=('x86_64' 'aarch64')
url="https://gitlab.com/wayfireplugins/${_pkgname}"
license=('MIT')
depends=('wayfire' 'wayland')
makedepends=('meson' 'ninja' 'glm')
-source=("https://gitlab.com/wayfireplugins/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz")
-md5sums=('bee49efa44c7d653c75d891dca1ac25a')
+source=("https://gitlab.com/wayfireplugins/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz"
+ "https://gitlab.com/wayfireplugins/windowmanager/-/commit/0bf81a1d1af06f624722325148d6d8f7d3dcf260.patch")
+md5sums=('bee49efa44c7d653c75d891dca1ac25a'
+ '1ccdefa3f69e44304c411ca0c5ba59f0')
+
+prepare() {
+ cd "${_pkgname}-v${pkgver}"
+ patch -Np1 -i ../0bf81a1d1af06f624722325148d6d8f7d3dcf260.patch #Fix compilation against wlroots 0.17
+}
build() {
cd "${_pkgname}-v${pkgver}"
- PKG_CONFIG_PATH=/usr/lib/wlroots0.16/pkgconfig meson setup .build --prefix=/usr --buildtype=release
+ meson setup .build --prefix=/usr --buildtype=release
ninja -C .build
}