summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJiachen Yang2015-08-10 19:31:28 +0900
committerJiachen Yang2015-08-10 19:31:28 +0900
commit7dc953260f86122a6f43f1ebf8527ce2e3cf3001 (patch)
tree4649d3fc923b18d6521b917fb77eef45c91cbc70 /PKGBUILD
downloadaur-wecase.tar.gz
takeover wecase
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12e9a5b34e00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: farseerfc <farseerfc@archlinuxcn.org>
+# Contributor: Tom Li <biergaizi@member.fsf.org>
+# Contributor: Star Brilliant <echo bTEzMjUzQGhvdG1haWwuY29tCg== | base64 -d>
+
+pkgname=wecase
+pkgver=0.06.beta8
+_pkgver=0.06-beta8
+pkgrel=1
+pkgdesc="A Sina Weibo Client Focusing on Linux"
+arch=('any')
+url="https://github.com/WeCase/WeCase"
+license=('GPL3')
+depends=('python>=3' 'pyqt>=4' 'python-notify2' 'python-rpweibo')
+source=("WeCase-${_pkgver}.tar.gz::https://github.com/WeCase/WeCase/archive/${_pkgver}.tar.gz")
+md5sums=("e38094778be778b309e25151bf9e4125")
+
+build() {
+ cd "$srcdir/WeCase-${_pkgver}"
+ ./bootstrap.sh
+ ./configure --prefix=/usr libexecdir=/usr/lib/wecase
+ make
+}
+
+package() {
+ export LANG=en_US.UTF-8
+ cd "$srcdir/WeCase-${_pkgver}"
+ make DESTDIR="$pkgdir/" install
+}