summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatteo Piccinini2024-05-05 19:28:12 +0200
committerMatteo Piccinini2024-05-05 19:28:25 +0200
commitc491cd576ccd2758119d40b911c6d970a552a520 (patch)
treeeeff333e227fbfe20f2b15df1e22ff3480c1d492 /PKGBUILD
parentcf5c5f4f0dc133b2c955f118c4206c12306aa076 (diff)
downloadaur-weechat-matrix.tar.gz
Cleanup pkgbuild from unnecessary preparation steps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4524681a19d1..6593828a2d18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=weechat-matrix
pkgver=0.3.0
-pkgrel=14
+pkgrel=15
pkgdesc='WeeChat Matrix protocol script written in Python'
arch=('any')
url='https://github.com/poljar/weechat-matrix'
@@ -37,25 +37,19 @@ source=("$pkgname-$pkgver.tar.gz::https://api.github.com/repos/poljar/$pkgname/t
b2sums=('fd4252ed0601d6daf22177bb5e3a3958ddad34191d05ec24cae074c16112c27e3825654f4ab3045c2676de465e409cbd6b1f7dac1957c57149ee5a7ee4e8c82c'
'e3a713a111505564d1ff7c34645b35a3f3aea2dde9bfac430beb4b28e60fc5557a40d4feafa28db3da7d66f55468570131b439256d8625dc98545dd15af7d7b9'
'c44468b5ef4f1a399d5d8b1c5e33809eb0bf8e5fdea17fd1ff3432c39ed557c2f73a557cd91bd0f552b48bd2a8244883905b1746e6d03dfd66545ee7cbb5f2c4'
- 'd88a9a84456eb702885e7cede88590a49f1e4563179f8b80b70f01c102969531cf80ce8bded2beb16010e276e3b8db0388339ea57a539049509a98d05e60699c')
+ '8df9cb35e43218b00a1c3e936b8dcc526c9b4bbc7c58c14ee2998b1e0365f3463946183fedd1abc2d5297cfd3903f38b469bf3d2e541f376d4b7dca5d10ac3d3')
prepare() {
tar zxvf "$pkgname-$pkgver.tar.gz" --strip-components=1 --one-top-level
cd "$pkgname-$pkgver"
- sed -ri 's|#!/usr/bin/env( -S)? python3|#!/usr/bin/python3|' contrib/*.py
- # Remove unnecessary dependency version pinning
- sed -i 's/= "^[0-9.]*"/= "*"/' pyproject.toml
- # fix PEP517 build-system definition: https://github.com/poljar/weechat-matrix/pull/340/files
- patch -Np1 -i ../0001-Switch-to-correct-build-system-definition.patch
- # update python-matrix-nio (0.20.1-1 -> 0.23.0-1) broke the plugin
- patch -Np1 -i ../0002-Fix-compatibility-with-matrix-nio-0.21.patch
- # SSLContext.set_npn_protocols broken in Python 3.10 (https://github.com/poljar/weechat-matrix/issues/308)
- patch -Np1 -i ../0003-server-remove-set_npn_protocols.patch
+ patch --forward --strip 1 --input ../0001-Switch-to-correct-build-system-definition.patch
+ patch --forward --strip 1 --input ../0002-Fix-compatibility-with-matrix-nio-0.21.patch
+ patch --forward --strip 1 --input ../0003-server-remove-set_npn_protocols.patch
}
build() {
cd "$pkgname-$pkgver"
- python -m build --wheel --no-isolation --skip-dependency-check
+ python -m build --wheel --no-isolation
}
check() {