summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Tarocchi2018-03-26 15:52:43 +0200
committerAndrea Tarocchi2018-03-26 15:52:43 +0200
commit1f512340ef16095aecdb371f83cdeb20c249e2ee (patch)
treedfc9405c95bcb698139cceac1737c23ba5a1200c /PKGBUILD
parente8c107940bb4a4f8dc5e34cd7a1e6c877720bee8 (diff)
downloadaur-1f512340ef16095aecdb371f83cdeb20c249e2ee.tar.gz
Updated to version 1.13.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 20 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index caa8d2e57e1e..eebd26fbaad2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
#Maintainer: Andrea Tarocchi <valdar@email.it>
pkgname=wesnoth-devel
-pkgver=1.13.11
+pkgver=1.13.12
pkgrel=1
pkgdesc="development version of a turn-based strategy game on a fantasy world"
arch=('i686' 'x86_64')
url="https://www.wesnoth.org/"
license=('GPL')
-depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'pango' 'fribidi' 'lua' 'dbus' 'openssl' 'boost-libs' 'desktop-file-utils' 'ttf-dejavu' 'ttf-droid' 'ttf-lato')
+depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'pango' 'fribidi' 'lua' 'dbus' 'openssl' 'boost-libs' 'desktop-file-utils')
optdepends=('python: some tools for UMC developers'
'python2: some tools for UMC developers'
'tk: for GUI.pyw, a gui for some of these tools'
@@ -18,27 +18,28 @@ optdepends=('python: some tools for UMC developers'
'advancecomp: png optimization with wesnoth-optipng / woptipng'
'imagemagick: png optimization with wesnoth-optipng / woptipng'
'libpng: png screenshots')
-makedepends=('boost' 'scons' 'libpng')
+makedepends=('boost' 'scons' 'pkg-config')
+checkdepends=('desktop-file-utils' 'appstream-glib')
install=${pkgname}.install
options=('!emptydirs')
#options=('!emptydirs' '!strip') #use this when building with debugging symbols
source=("https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.tar.bz2"
"${pkgname}.desktop"
"wesnoth_editor-devel.desktop"
- "wesnoth-devel-icon.xpm"
- "wesnoth-devel_editor-icon.xpm"
+ "${pkgname}-icon.png"
+ "${pkgname}_editor-icon.png"
"wesnothd-devel.tmpfiles.conf"
"wesnothd-devel.service"
"wesnoth-devel.appdata.xml")
-md5sums=('e1c22dd75f4d3edb1504a1dbd51ff750'
- 'fb3c2d5cfb93c8e8bce213f562c366e9'
- 'b9de9e7ee16f757aa406466657c274a9'
- 'b73f4fdefd3e7daa158cce278f11be64'
- '931e7443fe37b2862ca59f65ded74a0b'
+md5sums=('07e7de100810b154463c0de4337deb4e'
+ '719df848ebda176f995051ef9da302c6'
+ '049a22a72074277e53484e3a530d1d69'
+ '251f487241afda73c048b4fb654ceda7'
+ 'c5dc8ed0f8ece0b3990bfe367097509c'
'd9d4677b083eab179200e34c6dea8899'
'93f1afc41c66eb324a45ca26055f1507'
- 'b6da095ff0849b5fd95204702a257496')
+ 'eb0e7466413cd0cdf5ed535146e87f87')
PKGEXT='.pkg.tar'
@@ -52,6 +53,12 @@ prepare() {
#patch -p1 < ../../sdlmixer_2.0.2.patch
}
+check() {
+ cd "$srcdir"
+ desktop-file-validate --no-hints --no-warn-deprecated *.desktop
+ appstream-util validate-relax *.appdata.xml
+}
+
build() {
cd "$srcdir/wesnoth-$pkgver"
@@ -69,10 +76,10 @@ package(){
#INSTALLING of menu entry and icons and appstream information:
install -D -m644 "$srcdir/wesnoth-devel.desktop" "$pkgdir/usr/share/applications/wesnoth-devel.desktop"
- install -D -m644 "$srcdir/wesnoth-devel-icon.xpm" "$pkgdir/usr/share/pixmaps/$pkgname-icon.xpm"
+ install -D -m644 "$srcdir/wesnoth-devel-icon.png" "$pkgdir/usr/share/pixmaps/$pkgname-icon.png"
install -D -m644 "$srcdir/wesnoth_editor-devel.desktop" "$pkgdir/usr/share/applications/wesnoth_editor-devel.desktop"
- install -D -m644 "$srcdir/wesnoth-devel_editor-icon.xpm" "$pkgdir/usr/share/pixmaps/$pkgname_editor-icon.xpm"
+ install -D -m644 "$srcdir/wesnoth-devel_editor-icon.png" "$pkgdir/usr/share/pixmaps/${pkgname}_editor-icon.png"
install -D -m644 "$srcdir/wesnothd-devel.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/wesnothd-devel.conf"
install -D -m644 "$srcdir/wesnothd-devel.service" "$pkgdir/usr/lib/systemd/system/wesnothd-devel.service"