summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMiguel A. Vico2017-07-07 12:42:17 -0700
committerMiguel A. Vico2017-07-07 13:30:26 -0700
commit87ffac5fff77badfc6c0ecaa022ef7ca96278cd2 (patch)
tree4da9010927eed90ffa0e96848c7653b6e2a5e066 /PKGBUILD
parent801076ec4bdd14d681a580fbbbc0d9f2d690673e (diff)
downloadaur-87ffac5fff77badfc6c0ecaa022ef7ca96278cd2.tar.gz
Process stream attach requests with wl_eglstream_controller
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf3b69877b72..2b7b0c9a2be7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=weston-eglstream
pkgver=2.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Reference implementation of a Wayland compositor with EGLStream support'
arch=('i686' 'x86_64')
url='https://wayland.freedesktop.org/'
@@ -25,7 +25,8 @@ source=("https://wayland.freedesktop.org/releases/weston-$pkgver.tar.xz"
'0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch'
'0006-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch'
'0007-Add-nvidia-release-notes-file.patch'
- '0008-compositor-drm-Release-current-next-fb-when-deactiva.patch')
+ '0008-compositor-drm-Release-current-next-fb-when-deactiva.patch'
+ '0009-compositor-Process-stream-attach-requests-with-wl_eg.patch')
sha256sums=('b4e446ac27f118196f1609dab89bb3cb3e81652d981414ad860e733b355365d8'
'c81d07f0a2b26e772faa02e4b088ff979206216652a4c30beb9aa24631d9d648'
'c32048c7b1e57c24ca7fa665c9e70bc3c12dec338aea3643b637bf8d30188335'
@@ -34,7 +35,8 @@ sha256sums=('b4e446ac27f118196f1609dab89bb3cb3e81652d981414ad860e733b355365d8'
'8087849a01853e5c69fad7c9821e2202fd78ffe904626fe2f9ff51e83816ed02'
'3bb9b0a354aa07fb3eb89ad9b7e425b1ce980b1bd0b90166a41795a80acc78ca'
'47fc9f44083096299e1502cf15c93d9f8670e1a4e4784870d7a843d4de09d502'
- 'ca6c3a6fef381c6c7dd05e6d1bfda97b221fd90fc78ebf7b7ade9cfad2b38b63')
+ 'ca6c3a6fef381c6c7dd05e6d1bfda97b221fd90fc78ebf7b7ade9cfad2b38b63'
+ 'd9f0bb2ac862017d0a1f0bddd3fedb5d4e7be3b5af6dd579d75442f9f88acf63')
prepare() {
cd weston-$pkgver
@@ -47,6 +49,7 @@ prepare() {
patch -Np1 -i "${srcdir}/0006-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch"
patch -Np1 -i "${srcdir}/0007-Add-nvidia-release-notes-file.patch"
patch -Np1 -i "${srcdir}/0008-compositor-drm-Release-current-next-fb-when-deactiva.patch"
+ patch -Np1 -i "${srcdir}/0009-compositor-Process-stream-attach-requests-with-wl_eg.patch"
}
build() {