summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard Neumann2021-01-12 15:41:31 +0100
committerRichard Neumann2021-01-12 15:41:31 +0100
commit3618c868cc29053a375daae005b656c6d04eeaa8 (patch)
treed18ea9e30ae4efa9ca5167790241d007cb1e9952 /PKGBUILD
parent05cd1c45877eaeedfac2568deedc2928b01ba75a (diff)
downloadaur-wgmgr.tar.gz
Updated to 1.5.2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c523489e727e..7137dc4865b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
pkgname='wgmgr'
-pkgver=1.5.0
-pkgrel=3
+pkgver=1.5.2
+pkgrel=1
pkgdesc='Manages WireGuard PKIs for VPN-like deployments'
arch=('any')
url="https://github.com/coNQP/${pkgname}"
license=('GPLv3')
depends=('python' 'python-wgtools')
-makedepends=('git')
+makedepends=('git' 'python-setuptools-scm')
source=("git+${url}.git#tag=${pkgver}")
md5sums=('SKIP')
+build() {
+ cd "${pkgname}"
+ python setup.py build
+}
package() {
cd "${pkgname}"
- python setup.py install --root "${pkgdir}" --optimize=1
+ python setup.py install --root "${pkgdir}" --optimize=1 --skip-build
}