summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Wilper2023-01-28 18:53:33 +0100
committerSimon Wilper2023-01-28 18:53:33 +0100
commit4d24febe226848d8140bfaade089fd921ea3169c (patch)
treec14b0e15f8db84b983ce3ac1c93fbffea674b862 /PKGBUILD
parent364cccff3320c6a2411f73c6d5312e031f8caca5 (diff)
downloadaur-whatwg-html.tar.gz
Version 2023.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a462cb7bdbc..dc1e04662657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Simon Wilper <sxw@chronowerks.de>
pkgname=whatwg-html
-pkgver=2017_08
-pkgrel=2
+pkgver=2023.1
+pkgrel=1
pkgdesc="Clone the WHATWG HTML specification with local resources"
arch=('any')
url="https://www.github.com/whatwg/html-build"
license=('GPL')
makedepends=(git perl perl-lwp-protocol-https)
-_gitroot=https://www.github.com/whatwg/html-build.git
+_gitroot=https://www.github.com/whatwg/html-build.git/
_gitname='html-build'
-_htmlroot=https://github.com/whatwg/html.git
+_htmlroot=https://github.com/whatwg/html.git/
_html='html'
-build() {
+prepare() {
cd "$srcdir"
msg "Connecting to GIT server..."
@@ -28,7 +28,7 @@ build() {
msg "Clone completed."
fi
- msg "Cloning HTML..."
+ msg "Cloning ${_gitname}"
if [[ -d "$_html" ]]; then
msg "Updating..."
@@ -40,21 +40,25 @@ build() {
cd "$_html"
msg "Clone completed."
fi
+}
+build() {
+ cd "${srcdir}/${_gitname}"
msg "Starting build..."
+ cd html
mv source source.orig
- perl $startdir/download-resources.pl source.orig source
+
+ msg "Downloading Resources and Patching source"
+ perl ../../../download-resources.pl source.orig source
cd ..
- ./build.sh
- mv html/resources output/multipage/
+ ./build.sh -f
+ mv html/resources output/
}
package() {
cd "$srcdir/${_gitname}"
- mkdir -p ${pkgdir}/usr/share/doc/whatwg
- cp -rv output/multipage ${pkgdir}/usr/share/doc/whatwg/html
+ mkdir -p ${pkgdir}/usr/share/doc/whatwg/
+ cp -rv output/* ${pkgdir}/usr/share/doc/whatwg/
}
-
-# vim:set ts=2 sw=2 et: