summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOtto Sabart2015-06-30 09:55:33 +0000
committerOtto Sabart2015-06-30 09:55:33 +0000
commit55eb294aabdeef627ffb0e3c4a89d06bcd4e2e47 (patch)
tree14b34e40414e03766ff6ab65584793c19466751a /PKGBUILD
downloadaur-wifigw.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f771c283de79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sabart Otto - Seberm <seberm[at]gmail[dot].com
+
+pkgname=wifigw
+pkgver=20120909
+pkgrel=1
+pkgdesc="Login to VUT wifi network"
+url="https://github.com/seberm/wifigw"
+arch=('any')
+license=('GPLv3')
+install=
+source=()
+depends=('bash' 'curl')
+provides=''
+makedepends=('git')
+
+_gitname="$pkgname"
+_gitroot="git://github.com/seberm/${pkgname}.git"
+
+
+build() {
+ cd $srcdir
+ msg "Connecting to GIT (${_gitroot}) ..."
+
+ if [ -d "$_gitname" ]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files of ${_gitname} were updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+
+ install -D -m755 "$srcdir/$_gitname/${pkgname}.sh" "$pkgdir/usr/bin/${pkgname}"
+}