summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Wanders2018-06-16 00:46:09 +0200
committerTim Wanders2018-06-16 00:46:09 +0200
commit4a712f510cd6e0f1d7e10399c7fb480ceb3f53a0 (patch)
tree26a9cdc8fff6ef97954a9765cdd675f1e187d210 /PKGBUILD
downloadaur-wifikill-linux-git.tar.gz
Added PKGBUILD from upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7f74d972040
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Tim Wanders <timwanders241@gmail.com>
+_pkgname=wifikill-linux
+pkgname=wifikill-linux-git
+pkgver=1
+pkgrel=1
+pkgdesc="wifikill-linux: A simple wifikill script for linux"
+arch=('any')
+url="https://gitlab.com/tim241/${_pkgname}"
+license=('NONE')
+
+provides=('wifikill-linux')
+conflicts=('wifikill-linux')
+
+depends=('bash' 'dsniff' 'net-tools' 'nmap' 'gawk')
+
+source=("git+https://gitlab.com/tim241/${_pkgname}.git")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --always | sed -e 's|-|.|g'
+}
+
+package() {
+ cd "$_pkgname"
+ install -D -m=755 wifikill "$pkgdir/usr/bin/wifikill"
+}