summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Woffinden2015-06-08 23:10:27 +0100
committerDaniel Woffinden2015-06-08 23:10:27 +0100
commit66b6432108c027af293f88c68d3168aa56092061 (patch)
tree9312d01d499453c4a0c87b1c0e52dd4723d795b0 /PKGBUILD
downloadaur-wikititle-git.tar.gz
Squash history to appease the aur4 hooks.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..875a7bb8ee29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: d.woffinden
+pkgname=wikititle-git
+pkgver=r17.bb8b4da
+pkgrel=1
+pkgdesc='Simple PHP script for grabbing episode titles out of List of Episodes pages on Wikipedia with the Wikipedia API'
+arch=('any')
+url='https://github.com/javajawa/wikititle'
+license=('BSD')
+depends=('php')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/javajawa/wikititle.git")
+md5sums=('SKIP')
+
+# use the number of revisions since beginning of the history
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -D retitle "$pkgdir/usr/bin/retitle"
+ install -D wikititle "$pkgdir/usr/bin/wikititle"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+