summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:30:55 -0700
committerAaron DeVore2015-07-08 11:30:55 -0700
commitbb7d9ea0cdef46846f899edd97f6ba6e77ec0db7 (patch)
tree7122feb19779afa614bfc28ae517c76af3d383bc /PKGBUILD
downloadaur-wikkid-bzr.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b21478e3876
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+# Contributor: Georges Dubus <georges.dubus@compiletoi.net>
+pkgname=wikkid-bzr
+pkgver=74
+pkgrel=1
+pkgdesc="A wiki that is backed by Bazaar that allows local branching of the wiki for later merging. Also doesn't have any page locks and uses Bazaar's three way merging."
+arch=(any)
+url="https://launchpad.net/wikkid"
+license=(AGPL)
+depends=(bzr python2-pygments python2-jinja python2-webob python2-zope-interface
+ python2-docutils python2-lxml python2-markdown python2-beautifulsoup3)
+makedepends=(python2-setuptools)
+source=("bzr+http://bazaar.launchpad.net/~wikkid/wikkid/trunk/")
+md5sums=('SKIP')
+conflicts=('wikkid')
+
+pkgver() {
+ cd "$srcdir/trunk"
+ bzr revno
+}
+
+build() {
+ cd "$srcdir/trunk"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/trunk"
+ python2 setup.py install --root="$pkgdir"
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
+}