summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredmattski2022-10-26 08:31:16 +0200
committerredmattski2022-10-26 08:31:16 +0200
commit3dd611cf51f070bfeb6e89deef1bb79b20b41474 (patch)
tree0c5d76c8ec6e4fca780c08e0d025f1b6945ded59 /PKGBUILD
parent759ce40f2c563b81aa911fa381aeed1a8b0cdb71 (diff)
downloadaur-withings-sync.tar.gz
move to user service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2014d2e3b04c..5915153f5d44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=withings-sync
pkgver=v3.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="A tool for synchronisation of Withings (ex. Nokia Health Body) to Garmin Connect and Trainer Road."
arch=(any)
url="https://github.com/jaroslawhartman/withings-sync"
@@ -28,17 +28,19 @@ package() {
cd $pkgname
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
- install -Dm644 "${srcdir}/${pkgname}.timer" "${pkgdir}/usr/lib/systemd/system/${pkgname}.timer"
+ install -Dm644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/user/${pkgname}.service"
+ install -Dm644 "${srcdir}/${pkgname}.timer" "${pkgdir}/usr/lib/systemd/user/${pkgname}.timer"
install -Dm600 "${srcdir}/${pkgname}.conf.example" "${pkgdir}/etc/${pkgname}/${pkgname}.conf.example"
- echo "1.) Run withings-sync as the <local user> including enabling the access to withings"
- echo "2.) Add User=<local user> to the service file"
- echo "3.) Update the conf file with the Garmin username and PW"
- echo "4.) Enable the timer"
+ echo "1.) Initially run withings-sync from the cli for the <user> to enable the access to withings"
+ echo "2.) Copy Conf file to home directory and update with Garmin/Trainer Road Username & P/W"
+ echo "3.) Edit the service file to point to the conf file location"
+ echo " $systemctl --user edit --full withings-sync.service"
+ echo "4.) Enable the timer: $systemctl --user enable --now withings-sync.timer"
}
md5sums=('SKIP'
'cabc6d7ff62a22ed8b6722210c873bb6'
'fdcbfb1d8c6081077048da6d92b0721f'
'8c065062c737baae192fadb97a88abc1')
+