summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorendlesseden2022-07-09 06:45:17 +1000
committerendlesseden2022-07-09 06:45:17 +1000
commite729ac94b86536711c0666dc7b1e23c6fbd78afb (patch)
tree906efa1ac687561a2af8055b5b381abcfea8e737 /PKGBUILD
parentc118da02582ae140eca233c45df68a93159047d9 (diff)
downloadaur-wiwos20-git.tar.gz
Updated: Source location changed upstream... again...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7343a8f7754b..d4138542dd77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: EndlessEden
-pkgname=wiwos20
-pkgver=0.1
+_pkgname=wiwos20
+pkgname=$_pkgname-git
+pkgver=0.1.3ba16be
pkgrel=1
pkgdesc="S20 socket manager"
arch=('i686' 'x86_64')
@@ -8,17 +9,21 @@ url="https://git.stikonas.eu/andrius/s20"
license=('GPL')
depends=('qt5-base')
makedepends=('git')
-source=("$pkgname::git+https://git.stikonas.eu/andrius/s20.git")
+source=("$_pkgname::git+https://git.stikonas.eu/andrius/s20.git")
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir"/"$_pkgname"
+ echo "0.1.$(git rev-parse --short HEAD)"
+}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgname"
mkdir build
cd build
cmake ..
make
}
package() {
- cd "$srcdir/$pkgname"/build
+ cd "$srcdir/$_pkgname"/build
mkdir -p "$pkgdir/usr/bin/"
cp s20 "$pkgdir/usr/bin/"
cp s20-gui "$pkgdir/usr/bin/"