summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorilusi0n2015-10-23 20:22:16 +0100
committerilusi0n2015-10-23 20:22:16 +0100
commitf585bc7c83f90b4d614de0770f318ddbf6e85047 (patch)
tree0bc52928ccd1496f4f7898807678e278760ce545 /PKGBUILD
downloadaur-wmfs.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c67d1e8c02d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: ilusi0n <ridemetothemoon@gmail.com>
+# Contributor: Bartek Piotrowski <barthalion@gmail.com>
+# Contributor: AddiKT1ve <the.addikt1ve@gmail.com>
+
+pkgname=wmfs
+pkgver=201104
+pkgrel=1
+pkgdesc="A lightweight and highly configurable tiling window manager for X"
+arch=('i686' 'x86_64')
+url="http://www.wmfs.info/"
+license=('BSD')
+depends=('libxft' 'imlib2' 'libxinerama' 'libxrandr')
+conflicts=('wmfs-git' 'wmfs2-git')
+source=(https://github.com/downloads/xorg62/wmfs/wmfs-201104.tar.gz)
+md5sums=('323fa55885d86783f104f936e6b12c75')
+
+build() {
+cd "$srcdir/$pkgname-$pkgver"
+
+./configure --prefix /usr \
+--man-prefix /usr/share/man \
+--xdg-config-dir /etc/xdg
+make
+}
+
+package() {
+cd "$srcdir/$pkgname-$pkgver"
+
+make DESTDIR=${pkgdir} install
+install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+} \ No newline at end of file