summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorblindingdark2021-03-27 00:22:32 +0800
committerblindingdark2021-03-27 00:22:32 +0800
commite0d2edf3ee9fea8d9a86f6580c2be8c3bde6bd95 (patch)
tree69e3350ab94edfa515c2635abe894e812de0e6d1 /PKGBUILD
downloadaur-wordninja-rs-lua-git.tar.gz
init.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..789fa2ee5cd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: BlindingDark <blindingdark@outlook.com>
+
+pkgname=wordninja-rs-lua-git
+_pkgname=wordninja-rs-lua
+pkgver=b2f252a
+pkgrel=1
+pkgdesc="Wordninja Rust lua native module."
+url="https://github.com/BlindingDark/wordninja-rs-lua"
+makedepends=('cargo' 'lua')
+arch=('x86_64')
+license=('MIT')
+provides=(wordninja-rs-lua)
+conflicts=(wordninja-rs-lua)
+source=("git+https://github.com/BlindingDark/wordninja-rs-lua")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+ RUSTUP_TOOLCHAIN=stable cargo build --release --features lua54
+}
+
+package() {
+ cd $_pkgname
+ install -Dm755 target/release/libwordninja_rs_lua.so "$pkgdir/usr/lib/lua/5.4/wordninja.so"
+}