summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-09-25 17:31:23 +1200
committercaltlgin2020-09-25 17:31:23 +1200
commit409091f6c74ed45a1c59576b593903ffc04b58f2 (patch)
treed91f86d7d49f7ab93166fc1aaf191c1aafed53f6 /PKGBUILD
downloadaur-workspaces-git.tar.gz
Add to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..371285736560
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='workspaces'
+pkgname="${_pkgname}-git"
+pkgver=3.1.0.r0.gd3d69be
+pkgrel=1
+pkgdesc='Configure and quickly launch all you need to work on a project'
+arch=('x86_64')
+url='https://github.com/DevAlien/workspaces'
+license=('GPL3')
+depends=('granite')
+makedepends=('git' 'meson' 'vala')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson "${_pkgname}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${_pkgname}/README.md"
+}
+
+# vim: ts=2 sw=2 et: