summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOtto Sabart2015-06-30 09:55:38 +0000
committerOtto Sabart2015-06-30 09:55:38 +0000
commitbf203aa62dcf93ee3a8d00d63d12a4f3b5d4c94d (patch)
tree5570e252cc224605d359c6653ed2a071b97e90bd /PKGBUILD
downloadaur-wwwsqldesigner.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b949b821ad1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Sabart Otto - Seberm <seberm[at]seberm[dot]com>
+
+pkgname=wwwsqldesigner
+pkgver=2.7
+pkgrel=1
+pkgdesc="Visual web-based SQL modelling tool"
+url="http://code.google.com/p/wwwsqldesigner/"
+license=('BSD')
+arch=('any')
+depends=()
+optdepends=('apache')
+install=wwwsqldesigner.install
+makedepends=('subversion')
+source=("http://wwwsqldesigner.googlecode.com/files/${pkgname}-${pkgver}.zip")
+
+package() {
+ _instdir="$pkgdir/usr/share/webapps/$pkgname"
+ mkdir -p "$_instdir" "$pkgdir/etc/webapps/$pkgname" "$pkgdir/etc/httpd/conf/extra"
+
+ cp -ra $srcdir/${pkgname}-${pkgver}/* "$_instdir/"
+ chmod 0644 -R "$_instdir"
+
+ # It's similar to phpMyAdmin
+ cat >$pkgdir/etc/webapps/$pkgname/apache.example.conf <<EOF
+ Alias /${pkgname} "/usr/share/webapps/${pkgname}"
+ <Directory "/usr/share/webapps/${pkgname}">
+ AllowOverride All
+ Options FollowSymlinks
+ Require all granted
+ </Directory>
+EOF
+
+ cp "$pkgdir/etc/webapps/$pkgname/apache.example.conf" "$pkgdir/etc/httpd/conf/extra/httpd-${pkgname}.conf"
+ #echo "Include conf/extra/httpd-${pkgname}.conf" >> $pkgdir/etc/httpd/conf/httpd.conf
+
+ find "${_instdir}" -type d -exec chmod 755 {} \;
+}
+
+sha1sums=('3bc7a0a96be57a9c137f511b547759822aba8a13')