summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrancesco Zardi2023-08-28 14:28:13 +0200
committerFrancesco Zardi2023-08-28 14:28:13 +0200
commitd2fa3c7d8c6cdb6a89dfcb0724c2c44b48cdbee1 (patch)
tree64c091cf3c014a3e83a61cc6abb4d3d6c8fbc142 /PKGBUILD
parent6a9e9262c08570c8b12e2293c2a85f39deee58a7 (diff)
downloadaur-wxgtk2.8.tar.gz
Re-add gstreamer dependency and fix compilation error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 31 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0ccff73c88f..a82d6cef24c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,30 @@
-# Maintainer: Geyslan G. Bem <geyslan@gmail.com>
+# Maintainer: Francesco Zardi <fracar0 [at] hotmail _dot_ it>
+# Contributor: Geyslan G. Bem <geyslan@gmail.com>
# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Eric BĂ©langer <eric@archlinux.org>
pkgname=wxgtk2.8
pkgver=2.8.12.1
-pkgrel=7
+pkgrel=8
pkgdesc="GTK+ implementation of wxWidgets API for GUI"
arch=('i686' 'x86_64')
url="http://wxwidgets.org"
license=('custom:wxWindows')
-depends=('gtk2' 'sdl' 'libsm')
-makedepends=('gconf' 'glu')
+depends=('gtk2' 'gstreamer0.10-base' 'sdl' 'libsm')
+makedepends=('gstreamer0.10-base-plugins' 'gconf' 'glu')
provides=("wxgtk2.8=${pkgver}")
conflicts=('wxgtk2.8-light')
options=('!emptydirs')
-source=(http://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2
- wxGTK-collision.patch
- make-abicheck-non-fatal.patch
- wxGTK-2.8.12.1-r2-gcc6.patch)
+source=("http://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2"
+ 'wxGTK-collision.patch'
+ 'make-abicheck-non-fatal.patch'
+ 'wxGTK-2.8.12.1-r2-gcc6.patch'
+ 'disable-lto-in-configure.patch')
sha1sums=('05688dc03d61631750f5904273122bb40a2115f5'
'75d2292a0058570aa6071b4bee6eef69e47f1208'
'dfe38650c655395b90bf082b5734c4093508bfa3'
- 'f1a3bc30ec8139d97ca239dc1bf6cbc2ceb5c5d9')
+ 'f1a3bc30ec8139d97ca239dc1bf6cbc2ceb5c5d9'
+ 'd4f661d3a1fe324d8d6703b1da677fbbf10d46a7')
prepare() {
cd wx*-${pkgver}
@@ -34,14 +37,29 @@ prepare() {
# fix gcc6 narrowing error
# https://bugs.gentoo.org/show_bug.cgi?id=592442
patch -p1 -i ../wxGTK-2.8.12.1-r2-gcc6.patch
+
+ # Turn off LTO when compiling test programs in the "configure" script
+ patch -p1 -i ../disable-lto-in-configure.patch
}
build() {
cd wx*-${pkgver}
- ./configure --prefix=/usr --libdir=/usr/lib --with-gtk=2 --with-opengl --enable-unicode \
- --enable-graphics_ctx --disable-optimize --enable-mediactrl --with-regex=builtin \
- --with-libpng=sys --with-libxpm=sys --with-libjpeg=sys --with-libtiff=sys \
- --with-sdl --disable-precomp-headers
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --with-gtk=2 \
+ --with-opengl \
+ --enable-unicode \
+ --enable-graphics_ctx \
+ --disable-optimize \
+ --enable-mediactrl \
+ --with-regex=builtin \
+ --with-libpng=sys \
+ --with-libxpm=sys \
+ --with-libjpeg=sys \
+ --with-libtiff=sys \
+ --with-sdl \
+ --disable-precomp-headers
make
make -C locale allmo
make -C contrib/src