summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2022-01-29 01:50:08 -0700
committerBrian Bidulock2022-01-29 01:50:08 -0700
commit068dc4a3d5d87828f1378700349afd98d8515d72 (patch)
treec2d0f1b6eee429556349640a20f9b6ace117860a /PKGBUILD
parentc8261945c0bba3d73a4915d4b3bfe48578b619ba (diff)
downloadaur-xde-applets.tar.gz
version 0.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbbdb2b2a6db..ca366ff3d6d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,28 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=xde-applets
-pkgver=0.11
+pkgver=0.12
pkgrel=1
pkgdesc="X Desktop Environment System Tray Icons and Dock Apps"
groups=('xde')
arch=('i686' 'x86_64')
-url="https://github.com/bbidulock/xde-applets"
+url="https://github.com/bbidulock/$pkgname"
license=('GPL')
-depends=('libsm' 'libwnck+-git' 'libcanberra' 'libnotify' 'lm_sensors'
- 'libpackagekit-glib' 'cpupower' 'upower' 'gdk-pixbuf-xlib')
-makedepends=('dbus-glib' 'libunique' 'xorgproto')
+depends=('libwnck+-git' 'libcanberra' 'libnotify' 'lm_sensors')
+makedepends=('dbus-glib' 'libunique' 'xorgproto' 'libpackagekit-glib' 'cpupower' 'upower' 'gdk-pixbuf-xlib')
optdepends=('xdg-launch-git: launch with recent update and launch notification')
source=("https://github.com/bbidulock/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.lz")
-md5sums=('1c850b9efd1854229c5d0a0f60db67f5')
+md5sums=('91de2f4a40efc306866515e316a80525')
build() {
cd $pkgname-$pkgver
# gtk2 is using deprecated glib2 declarations
./configure CFLAGS="-Wno-deprecated-declarations $CFLAGS"
# Fight unused direct deps
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+ sed -i -e "s| -shared | $LDFLAGS\0 |g" -e "s| if test \"\$export_dynamic\" = yes && test -n \"\$export_dynamic_flag_spec\"; then| func_append compile_command \" $LDFLAGS\"\n func_append finalize_command \" $LDFLAGS\"\n\0|" libtool
make CFLAGS="-Wno-deprecated-declarations $CFLAGS"
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
}