summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2022-01-29 00:26:21 -0700
committerBrian Bidulock2022-01-29 00:26:21 -0700
commit3ced6e1a485e2107b41dda7fdb9ddc0f7c03aba5 (patch)
treedd2c27e58ae95f4d48790ac98e69d85630dcd8de /PKGBUILD
parent6376e8263b8d5ba54b5a3c4e65197223f1b7f24e (diff)
downloadaur-xdg-launch.tar.gz
version 1.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80cf8d1ee7ea..1228a47346af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=xdg-launch
-pkgver=1.11
+pkgver=1.12
pkgrel=1
pkgdesc="A command line XDG compliant launcher"
arch=('i686' 'x86_64')
url="http://github.com/bbidulock/${pkgname}"
license=('GPL')
groups=('xde')
-depends=('glib2' 'libxrandr' 'libxinerama' 'desktop-file-utils')
+depends=('glib2' 'libxrandr' 'libxinerama')
optdepends=('dmenu: to use dmenu_launch script')
makedepends=('pkgconfig')
source=("https://github.com/bbidulock/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.lz")
-sha256sums=('ce4c8f07624b457aaeb806846573aa662f816a85a5f49fc1a7459132824bb6ef')
+sha256sums=('de4b84f46a3480b56236c40ac09f8dfa226fbd3b5e7d13e92b6af9fb26ddbf9d')
build() {
- cd ${pkgname}-${pkgver}
+ cd $pkgname-$pkgver
./configure
+ # Fight unused direct deps
+ sed -i -e "s| -shared | $LDFLAGS\0 |g" -e "s| if test \"\$export_dynamic\" = yes && test -n \"\$export_dynamic_flag_spec\"; then| func_append compile_command \" $LDFLAGS\"\n func_append finalize_command \" $LDFLAGS\"\n\0|" libtool
make
}
package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
+ make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et: