summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2022-09-22 13:52:15 +0300
committerYurii Kolesnykov2022-09-22 13:52:15 +0300
commita0a686b086a94ac8bb496961b0b06dd3dcd84612 (patch)
tree7a1100ce1d71a46d59a0975881cdbd67acb2439d /PKGBUILD
parentcaa377e69468401b5f1893f90caa187786b318a8 (diff)
downloadaur-xf86-video-nouveau-git.tar.gz
sync with core/xf86-video-nouveau:
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13bc13b23742..32deed09b94f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
-# Contributor: Andreas Rammhold <andreas@rammhold.de>
-# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# based on core/xf86-video-nouveau: Andreas Radke <andyrtr@archlinux.org>
# Contributor: buddabrod <buddabrod@gmail.com>
+#
+# Send PRs here: https://github.com/yurikoles-aur/xf86-video-ati-git
+#
pkgname=xf86-video-nouveau-git
_pkgname=xf86-video-nouveau
-pkgver=1.0.17.r2.g3ee7cbc
-pkgrel=2
+pkgver=1.0.17.r5.g29cc528
+pkgrel=1
pkgdesc='Open Source 3D acceleration driver for nVidia cards (git version)'
arch=('x86_64')
url="https://nouveau.freedesktop.org/"
license=('GPL')
groups=('xorg-drivers-git')
depends=('systemd-libs' 'mesa')
-makedepends=('git' 'xorg-server-devel' 'xorg-server' 'systemd')
+makedepends=('xorg-server-devel' 'xorg-server' 'systemd' 'git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("${pkgname}::git://anongit.freedesktop.org/nouveau/xf86-video-nouveau")
+source=("${pkgname}::git+https://gitlab.freedesktop.org/xorg/driver/xf86-video-nouveau.git")
sha256sums=('SKIP')
pkgver() {
@@ -35,20 +37,15 @@ build() {
# Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
# With them, module fail to load with undefined symbol.
# See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
- export CFLAGS="${CFLAGS/-fno-plt}"
- export CXXFLAGS="${CXXFLAGS/-fno-plt}"
- export LDFLAGS="${LDFLAGS/,-z,now}"
+ export CFLAGS=${CFLAGS/-fno-plt}
+ export CXXFLAGS=${CXXFLAGS/-fno-plt}
+ export LDFLAGS=${LDFLAGS/,-z,now}
./configure --prefix=/usr
make
}
-check() {
- cd "${pkgname}"
- make check
-}
-
package() {
cd "${pkgname}"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" install
}