summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDeckweiss2022-05-28 15:00:57 +0200
committerDeckweiss2022-05-28 15:00:57 +0200
commit5e4491f06e0a7cf7bbdd80d210665e48c1c14eef (patch)
tree5de3bf7f1c1b1ae21bcb1d6efda3f57a0b3c5e0c /PKGBUILD
downloadaur-xinputd-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de5dcf154f5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Deckweiss <Deckweiss75@gmail.com>
+
+_name="xinputd"
+pkgname="${_name}-git"
+pkgver=1.0.0e0bd7c
+pkgrel=1
+pkgdesc="Xinputd is a simple daemon that executes a command when an Xorg input device is added or removed. By default, Xinputd forks to background and exits when the X server exits."
+arch=('any')
+url="https://github.com/bbenne10/${_name}"
+license=('MIT')
+depends=(asciidoc)
+optdepends=()
+makedepends=('git')
+conflicts=(${_name})
+provides=(${_name})
+source=("git+https://github.com/bbenne10/$_name.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ printf "1.0.%s" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_name"
+
+ make
+}
+
+package() {
+ cd "$_name"
+
+ make DESTDIR="$pkgdir/" xinputd.1
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}