summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Keen2022-03-04 00:33:03 -0500
committerKyle Keen2022-03-04 00:33:03 -0500
commit3a333674721e8f50179f111dafe968bf212db3c5 (patch)
tree58c971469595d3747d580ac816bdfcd5e7b2f841 /PKGBUILD
parentab81b161bb27bf4918678594ab3176a76b47edc5 (diff)
downloadaur-xnec2c.tar.gz
4.4.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd2222576103..410788b44a86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,31 @@
# Contributor: Vitaliy Berdinskikh ur6lad[at]i.ua
pkgname=xnec2c
-pkgver=4.1.5
+pkgver=4.4.6
pkgrel=1
pkgdesc="GTK+ Antenna EM Modeling Client"
arch=('i686' 'x86_64')
-#url="http://5b4az.chronos.org.uk/pages/nec2.html"
-#url="http://web.archive.org/web/20110724184011/http://5b4az.chronos.org.uk/pages/nec2.html"
-url="http://www.qsl.net/5b4az/pkg/nec2/xnec2c/doc/xnec2c.html"
+url="https://www.xnec2c.org/"
license=('GPL')
-depends=('gtk2')
+depends=('gtk3')
optdepends=('gnuplot: to use plotted output/data files')
-#source=(http://5b4az.chronos.org.uk/pkg/nec2/$pkgname/$pkgname-$pkgver.tar.bz2
-#source=(http://pkgs.fedoraproject.org/repo/pkgs/$pkgname/$pkgname-$pkgver.tar.bz2/d3c1d34da5519cf66ff429de51c6c768/$pkgname-$pkgver.tar.bz2
-source=("http://www.qsl.net/5b4az/pkg/nec2/xnec2c/xnec2c-$pkgver.tar.bz2"
+source=("$pkgname-$pkgver.tgz::https://github.com/KJ7LNW/xnec2c/archive/refs/tags/v$pkgver.tar.gz"
"$pkgname.desktop"
"http://bjensen.fedorapeople.org/pkgs/hams/icon/Ham_Icon-1-48.png")
-md5sums=('b2fecab6c6890141f1a1503484e0e5b5'
+md5sums=('1d36625ba3cffd9983e932494b1656d8'
'824c296ecb84175a5fa0905b8f357796'
'38378f273628bd9a28d3e5f9ff39fa18')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
# weird error where it installs the file to a location it won't read from?
- sed -i 's|"/.xnec2c/xnec2c.glade"|"/.xnec2c/xnec2c/xnec2c.glade"|' src/main.c
+ #sed -i 's|"/.xnec2c/xnec2c.glade"|"/.xnec2c/xnec2c/xnec2c.glade"|' src/main.c
}
build() {
cd "$srcdir/$pkgname-$pkgver"
# or add AC_SEARCH_LIBS(clogl, m) to configure.in
- sed -i 's/1.14/1.15/g' {autogen.sh,aclocal.m4}
+ #sed -i 's/1.14/1.15/g' {autogen.sh,aclocal.m4}
./autogen.sh
./configure --prefix=/usr LDFLAGS=-lm
make
@@ -38,12 +34,12 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- mkdir -p "$pkgdir/usr/share/"{applications,pixmaps}
+ #mkdir -p "$pkgdir/usr/share/"{applications,pixmaps,examples/xnec2c}
make DESTDIR="$pkgdir" install
# 4.1.2's improved install doesn't do these
- install -m644 examples/* "$pkgdir/usr/share/examples/$pkgname/"
+ #install -m644 examples/* "$pkgdir/usr/share/examples/$pkgname/"
# check if the upstream desktop can replace ours
install -m644 ../*.desktop "$pkgdir/usr/share/applications/"