summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDenilson Sá Maia2023-03-20 11:48:38 +0100
committerDenilson Sá Maia2023-03-20 11:48:38 +0100
commit8453cdb632f71a0eefa3376c5e97ecb08d1a6ca5 (patch)
tree6cc08a04fd974caad38c08c1975c65a86c74cfa4 /PKGBUILD
parentfe638ff6fd32744bccf2789f3600d01a2383f094 (diff)
downloadaur-xpuz.tar.gz
Fixed the package compilation
The upstream Makefile fails to link libjpeg statically. It also doesn't install the manpage by default. And it also doesn't install the manpage at the right directory. The previously supplied custom Makefile builds fine, but the program segfaults shortly after launching. Thus, in this commit I chose to fix the upstream Makefile and ditch the custom one.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f88c12a98d9f..f1f134602ac2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,21 @@
pkgname=xpuz
_pkgname=xpuz
pkgver=2.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="A fork of xjig 2.5, the jigsaw puzzle."
arch=('x86_64')
-url="http://webmayo.com/xjigsaw/"
+url="https://xjigsaw.net/"
license=('GPL3')
makedepends=('git')
depends=('libx11' 'libjpeg-turbo')
-source=("$pkgname::git+https://github.com/JeanLucJFr/$_pkgname.git" "Makefile")
-md5sums=('SKIP'
- '6d74c47275d958909ac9a496fc8db541')
+source=("$pkgname::git+https://github.com/JeanLucJFr/$_pkgname.git")
+md5sums=('SKIP')
prepare() {
cd "$srcdir/$pkgname"
- cp ../Makefile Makefile
- cp xpuz.man xpuz.6
- gzip xpuz.6
- }
+ # Statically linking libjpeg doesn't work for some unknown reason.
+ sed -i 's/-Wl,-Bstatic//' Makefile
+}
build() {
cd "$srcdir/$pkgname"
@@ -27,5 +25,5 @@ build() {
package() {
cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" MANSECT="6" PROJECTMANSUFFIX="" install install.man
}