summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryesuu2015-08-20 01:11:01 +0800
committeryesuu2015-08-20 01:11:01 +0800
commit22826ad6f1eaa1bbc38f5c768b2c27a17d59f94b (patch)
tree90f7efc4a2ca4d3f790c8245afd04b1a797cadec /PKGBUILD
downloadaur-xpybutil-git.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df3fa51caaed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: yesuu zhang <yesuu79@qq.com>
+
+pkgname=xpybutil-git
+pkgver=r89.8ee7dc4
+pkgrel=1
+pkgdesc='An incomplete xcb-util port plus some extras'
+arch=('any')
+url='https://github.com/BurntSushi/xpybutil'
+license=('custom:WTFPL')
+makedepends=('git')
+depends=('python2' 'xpyb-git')
+optdepends=('python-imaging')
+source=('git+https://github.com/BurntSushi/xpybutil.git')
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}/xpybutil"
+ python2 ./setup.py install --root=$pkgdir
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s -f /usr/share/doc/xpybutil/COPYING "${pkgdir}/usr/share/licenses/${pkgname}"
+}