summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMahdi N2023-04-03 17:19:15 +0300
committerMahdi N2023-04-03 17:19:15 +0300
commitab1391e148a8baeee271f77ea6fe22539d5117b8 (patch)
tree645563188b4be5a14e658c8d896d30dbc7a150bc /PKGBUILD
downloadaur-xsmon.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d84878a44761
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Mahdi N. <mhdna@outlook.com>
+# Upstream author : Sergey Vlasov <https://github.com/noscript/>
+
+pkgname=xsmon
+pkgver=0.3.r0.g7979a9b
+pkgrel=1
+pkgdesc='Extra small system monitor for X11'
+arch=('i686' 'x86_64')
+url="https://github.com/$pkgname/$pkgname"
+license=('MIT')
+makedepends=('git')
+depends=('libxcb')
+
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build(){
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 README.md -t"$pkgdir/usr/share/doc/$pkgname/"
+}