summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornate2018-03-29 18:13:40 -0500
committernate2018-03-29 18:13:40 -0500
commit8eca7ea8e5e38d70121eed07d60de38cdbcd8837 (patch)
tree97d69d37f596e1b9d6670541d445db5a71635254 /PKGBUILD
parent124dff2624680fd192b0881852712db5b4af4002 (diff)
downloadaur-8eca7ea8e5e38d70121eed07d60de38cdbcd8837.tar.gz
Replaced gnome-desktop dep with cinnamon-desktop
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac08447cb23d..e16d794711a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,25 @@
pkgname=xviewer
pkgver=1.6.1
-pkgrel=2
+pkgrel=3
pkgdesc="A simple and easy to use image viewer. X-Apps Project."
arch=('i686' 'x86_64' 'armv7h')
license=('GPL')
-depends=('gtk3' 'glib2' 'gnome-desktop' 'libpeas')
+depends=('gtk3' 'glib2' 'cinnamon-desktop' 'libpeas')
makedepends=('gnome-common' 'libglade' 'gobject-introspection')
optdepends=('xviewer-plugins: Extra plugins')
provides=($pkgname)
conflicts=('xviewer-git')
url='https://github.com/linuxmint/xviewer'
-install=xviewer.install
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/linuxmint/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('583cba9c604f3f48b4bf36c18bdc885b')
+_upstreamversion='master.mint19' # Hmmm...
+
+source=("${pkgname}-${pkgver}-${pkgrel}.tar.gz::https://github.com/linuxmint/${pkgname}/archive/${_upstreamversion}.tar.gz")
+md5sums=('43df95793771b6ba65b7e0e650994591')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${pkgname}-${_upstreamversion}
+
gnome-autogen.sh --prefix="/usr" \
--localstatedir="/var" \
--libexecdir="/usr/lib/${pkgname}"
@@ -26,6 +28,6 @@ build() {
}
package(){
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${pkgname}-${_upstreamversion}
make DESTDIR="$pkgdir/" install
}