summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlain Kalker2015-07-01 17:02:33 +0200
committerAlain Kalker2015-07-01 17:02:33 +0200
commitb08659bb4d867461f25f26dffb5187b09795057f (patch)
tree4d84ea52604ff70eda2fd6c0b7dbc1397a4048fd /PKGBUILD
downloadaur-xweston.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12f4ffd26c08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Alain Kalker <a {dot} c {dot} kalker "at" gmail {dot} com>
+pkgname=xweston
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Use X display managers and window managers with Xwayland and weston"
+arch=('any')
+url="https://github.com/ackalker/Xweston"
+license=('MIT')
+depends=('weston' 'xorg-server-xwayland')
+conflicts=('xweston-git')
+install=
+source=(Xweston-${pkgver}.tar.gz::https://github.com/ackalker/Xweston/archive/v${pkgver}.tar.gz)
+md5sums=('7db267d4481229368e6c9c1e1075cafe')
+
+package() {
+ cd "$srcdir/Xweston-${pkgver}"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}