summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgilcu32024-05-03 13:12:19 +0200
committergilcu32024-05-03 13:12:19 +0200
commita9dd96d953af9a73c341e2685196996033cd4ced (patch)
treea80e91fdf67922228b8c86ec8685ce859e9dac8f /PKGBUILD
parent395d59d32deabb33ad031604ed483a3a6d8996a5 (diff)
downloadaur-yafu-git.tar.gz
upgpkg: yafu-git r611.53d86bb-1
fix compile
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b304b880ac31..7376cd2f3f45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase=yafu
pkgname=yafu-git
pkgrel=1
-pkgver=r468.ca48c65
+pkgver=r611.53d86bb
pkgdesc="Automated integer factorization."
url=https://github.com/bbuhrow/yafu
license=("MIT")
@@ -19,13 +19,19 @@ source=(
"git+https://github.com/bbuhrow/ytools.git"
"git+https://github.com/bbuhrow/ysieve.git"
msieve::"svn+svn://svn.code.sf.net/p/msieve/code/trunk"
+ "avx_ecm_main.patch"
)
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '2fa4529955996166f4d258e2cb1a93685a4a8485129314d44fa3e140ae97e595')
prepare() {
cd ${srcdir}/yafu
sed -i "s%^LIBS += -lecm /users/buhrow/src%#LIBS += -lecm /users/buhrow/src%" Makefile
sed -i "s/^\#LIBS += -lecm -lgmp -lytools -lysieve/LIBS += -lecm -lgmp -lytools -lysieve/" Makefile
+ patch --forward --strip=1 --input=../avx_ecm_main.patch
}
pkgver() {