summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Eduardo Moreira dos Santos2017-08-11 16:40:48 -0300
committerCarlos Eduardo Moreira dos Santos2017-08-11 16:40:48 -0300
commit285b584aa237360dc873ce91d6406a412450e51c (patch)
tree2a990be9e928e8b5958d3e94047ddc74ed394e2f /PKGBUILD
downloadaur-yala.tar.gz
Initial commit: version 1.0.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e91aea6a4efa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Carlos Eduardo Moreira dos Santos <cems (at) cemshost DOT com (dot) br>
+pkgname=yala
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Combine Python linters in a sane way"
+arch=('any')
+url="https://github.com/cemsbr/yala"
+license=('MIT')
+groups=()
+depends=('pydocstyle' 'python-pycodestyle' 'python-pyflakes' 'python-pylint'
+ 'python-radon')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://pypi.python.org/packages/96/2f/821fec29b1d1b3e0a1f599d126e15d5e0f1f1a418386173c2df9d068fe4b/$pkgname-$pkgver.tar.gz")
+noextract=()
+sha256sums=('54666b00ed8c488cc74b1f1260923f57e8a8521452c46de9df0f64103a100db8')
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}